Premium SMS: 3 Sweden charging issues
Incident Report for Cellsynt AB
Resolved
The incident was resolved at 2022-09-06 23:38.
We have monitored the situation since then and can confirm everything is back to normal.
Posted Sep 07, 2022 - 08:17 CEST
Identified
3 Sweden just provided us with a short update:

"The database restore is progressing according to plan but ETR has been moved to 2022-09-07 at 00:00 CEST (so another ~7 hours from now). Further updates will be sent when we have more information."
Posted Sep 06, 2022 - 17:17 CEST
Update
We will continue to monitor the situation and let you know if we receive updates on the development of the situation.
Posted Sep 06, 2022 - 12:03 CEST
Investigating
3 Sweden is currently experiencing technical issues which affects the majority of all charged transactions for their subscribers. The root cause is a corrupt database in 3's technical platform which they are now in the process of restoring. Unfortunately, restoring the database is expected to take some time and current expected time of completion is 20:00.

Our platform automatically retries charging a number of times before giving up and during this time the transaction status will be seen as "unknown". Eventually, if we are unable to charge a subscriber, transaction status will be updated to "failed".
Posted Sep 06, 2022 - 09:45 CEST
This incident affected: Premium SMS HTTP API.